12bet live chat_bodog poker shut down_free login betdaq reviews

free online bettingSun, 02 Dec 2018 11:39:30 -0800

Source: r-cran-rgenoud
Version: 5.8-2.0-2
X-Debbugs-CC: debian...@lists.debian.org, gl...@packages.debian.org
User: debian...@lists.debian.org
Usertags: needs-update
Control: affects -1 src:glibc

Dear maintainers,

With a recent upload of glibc the autopkgtest of r-cran-rgenoud fails in
testing when that autopkgtest is run with the binary packages of glibc
from unstable. It passes when run with only packages from testing. In
tabular form:
                       pass            fail
glibc        from testing    2.28-1
r-cran-rgenoud         from testing    5.8-2.0-2
versioned deps [0]     from testing    from unstable
all others             from testing    from testing

I copied some of the output at the bottom of this report.

Currently this regression is contributing to the delay of the migration
of glibc to testing [1]. Of course, glibc shouldn't just break your
autopkgtest (or even worse, your package), but it seems to me that the
change in glibc was intended and your package needs to update to the new
situation. If needed, please change the bug's severity.

If this is a real problem in your package (and not only in your
autopkgtest), the right binary package(s) from glibc should really add a
versioned Breaks on the unfixed version of (one of your) package(s).
Note: the Breaks is nice even if the issue is only in the autopkgtest as
it helps the migration software to figure out the right versions to
combine in the tests.

More information about this bug and the reason for filing it can be found on
free online bettinghttps://wiki.debian.org/ContinuousIntegration/RegressionEmailInformation

Paul

[0] You can see what packages were added from the second line of the log
file quoted below. The migration software adds source package from
unstable to the list if they are needed to install packages from
glibc/2.28-1. I.e. due to versioned dependencies or breaks/conflicts.
[1] https://qa.debian.org/excuses.php?package=glibc

https://ci.debian.net/data/autopkgtest/testing/amd64/r/r-cran-rgenoud/1418394/log.gz

> test_check("rgenoud")
Loading required package: rgenoud
##  rgenoud (Version 5.8-2.0, Build Date: 2018-04-03)
##  See http://sekhon.berkeley.edu/rgenoud for additional documentation.
##  Please cite software as:
##   Walter Mebane, Jr. and Jasjeet S. Sekhon. 2011.
##   ``Genetic Optimization Using Derivatives: The rgenoud package for R.''
##   Journal of Statistical Software, 42(11): 1-26.
##

-- 1. Failure: Tests the new version of genoud() where the seeds are not
given (
biclaw1$value not equal to 1.65353.
1/1 mismatches
[1] 1.67 - 1.65 == 0.0176

-- 2. Failure: Tests the new version of genoud() where the seeds are not
given (
biclaw1$par not equal to c(-0.5001947, -0.5001947).
2/2 mismatches (average diff: 0.5)
[1] -1 - -0.5 == -0.5
[2] -1 - -0.5 == -0.5

-- 3. Failure: Tests the new version of genoud() where the seeds are not
given (
biclaw1$gradients not equal to c(-1.526799e-06, -8.571643e-07).
1/2 mismatches
[1] -3e-09 - -1.53e-06 == 1.52e-06

== testthat results
===========================================================
OK: 22 SKIPPED: 0 FAILED: 3
1. Failure: Tests the new version of genoud() where the seeds are not
given (@test-genoud_no_given_seed.R#84)
2. Failure: Tests the new version of genoud() where the seeds are not
given (@test-genoud_no_given_seed.R#85)
3. Failure: Tests the new version of genoud() where the seeds are not
given (@test-genoud_no_given_seed.R#86)

Error: testthat unit tests failed
Execution halted
autopkgtest [04:54:09]: test run-unit-test: -----------------------]

Attachment: signature.asc
Description: OpenPGP digital signature

Reply via email to