Welfare offer real madrid sponsors_Register for self-service experience_188bet contact

Wed, 31 Oct 2018 20:06:32 -0700

Thank you for the feedback, Konstantin and Darin.

On Thu, Nov 1, 2018 at 1:52 AM Darin Adler <da...@apple.com> wrote:

>
> With a few seconds thought I am thinking that maybe UTF8Conversion.h or
> UTF8Transcoding.h are possible better ideas for new names. Neither is
> completely accurate. If we were going to add the word ¡°helpers¡± than I
> would say UTF8Helpers.h, but I really don¡¯t like those kinds of word in
> header names (¡°utilities¡±, ¡°helpers¡±, ¡°functions¡±, ¡°classes¡±).
>

Sounds good. I take UTF8Conversion.h.


> A separate issue once we rename: the header is also pretty old and crufty.
> Eventually we might want to remove or refine the functions in here. Not
> sure how widely they are used.
>

 There are 8 functions in the header.

Following 2 functions are used only in
JavaScriptCore/runtime/JSGlobalObjectFunctions.cpp.

* UTF8SequenceLength
* decodeUTF8Sequence

Following 3 functions are used only in WTF/wtf/text/AtomicStringImpl.cpp

* calculateStringHashAndLengthFromUTF8MaskingTop8Bits
* equalUTF16WithUTF8
* equalLatin1WithUTF8

Following 3 functions are widely used

* convertUTF8ToUTF16
* convertLatin1ToUTF8
* convertUTF16ToUTF8

Any suggestions are welcome to improve.
_______________________________________________
webkit-dev mailing list
webkit-dev@lists.webkit.org
https://lists.webkit.org/mailman/listinfo/webkit-dev
free online betting

Reply via email to