betfred mobile_login bonus list of uk online casinos_bet mobile app

free online bettingWed, 19 Dec 2018 13:15:46 -0800

> On Dec 19, 2018, at 12:33 PM, Michael Catanzaro <> wrote:
> On Tue, Dec 18, 2018 at 9:31 PM, Darin Adler <> wrote:
>> I¡¯ve gotten used to the name AtomicString over the years, but I wouldn¡¯t 
>> strongly object to changing it if other programmers are often confused by 
>> it¡¯s similarity to the term ¡°atomic operations¡±.
> Well there were two other developers in the thread Ryosuke linked to who made 
> the exact same mistake as me, so I do think the current name is problematic. 
> A change wouldn't need to be drastic, though. I think suggestions from the 
> old thread like "StringAtom" or "AtomString" would be unproblematic. The 
> problem is the specific word "atomic" carries an expectation that the object 
> be safe to access concurrently across threads without locks; I think that 
> expectation doesn't exist if not for the "ic" at the end.
> FWIW I've only ever heard the "interned string" terminology prior to now.



webkit-dev mailing list

Reply via email to