login bonus winamax series 2019_Welfare offer betfair app download apk_login bonus bet365 apk 2019

Wed, 19 Dec 2018 21:20:46 -0800


> On Dec 19, 2018, at 8:06 PM, Ryosuke Niwa <rn...@webkit.org> wrote:
> 
> On Wed, Dec 19, 2018 at 1:13 PM Simon Fraser <simon.fra...@apple.com 
> <mailto:simon.fra...@apple.com>> wrote:
> > On Dec 19, 2018, at 12:33 PM, Michael Catanzaro <mcatanz...@igalia.com 
> > <mailto:mcatanz...@igalia.com>> wrote:
> > 
> > On Tue, Dec 18, 2018 at 9:31 PM, Darin Adler <da...@apple.com 
> > <mailto:da...@apple.com>> wrote:
> >> I¡¯ve gotten used to the name AtomicString over the years, but I wouldn¡¯t 
> >> strongly object to changing it if other programmers are often confused by 
> >> it¡¯s similarity to the term ¡°atomic operations¡±.
> > 
> > Well there were two other developers in the thread Ryosuke linked to who 
> > made the exact same mistake as me, so I do think the current name is 
> > problematic. A change wouldn't need to be drastic, though. I think 
> > suggestions from the old thread like "StringAtom" or "AtomString" would be 
> > unproblematic. The problem is the specific word "atomic" carries an 
> > expectation that the object be safe to access concurrently across threads 
> > without locks; I think that expectation doesn't exist if not for the "ic" 
> > at the end.
> > 
> > FWIW I've only ever heard the "interned string" terminology prior to now.
> 
> SingletonString?
> UniquedString?
> 
> I do like UniquedString. That conveys what AtomicString really is. 
> SingletonString isn't so great since AtomicString table is still per thread.

So hard to pronounce though! Why not UniqueString? It¡¯s not quite as explicit 
but close enough. 

Cheers,
Maciej

_______________________________________________
webkit-dev mailing list
webkit-dev@lists.webkit.org
https://lists.webkit.org/mailman/listinfo/webkit-dev

Reply via email to